Could not load type ‘System.Data.Entity.Design.AspNet.EntityDesignerBuildProvider’.


I got this error when upgrading from RC1 of Visual Studio 2010 and the .NET Framework 4.0 RC1, to the RTM version of both. The fix is simple, very simple; simple add the outlined markup to your web.config file.

<configuration>
   ...
   <system.web>
     <compilation debug="true" targetFramework="4.0">
       <assemblies>
         <add assembly="System.Security, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
         <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
         <add assembly="System.Data.Entity.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
       </assemblies>
       <buildProviders>
         <add extension=".edmx" type="System.Data.Entity.Design.AspNet.EntityDesignerBuildProvider" />
       </buildProviders>
     </compilation>
   </system.web>
</configuration>
Advertisements

One thought on “Could not load type ‘System.Data.Entity.Design.AspNet.EntityDesignerBuildProvider’.

  1. Thanks a lot. I had the same problem when upgrading from RC1 to release. Good job 🙂

Comments are closed.